Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 27. Mai 2015 12:03

hibr01
hat von CMS/ms gehört
Registriert: 06. Mai 2015
Beiträge: 5

[GELÖST] FrontEndUsers 1.28 Backendfehler mit CMSms 1.12

JFYI: Nach dem Update von CGExtensions 1.46.4 und v.a. dem FronEndUsers auf 1.28 zeigte letzterer im Backend eine "Oops"-Fehlermeldung. Ich benutze CMsms 1.12.

Das Downgrade auf FEU 1.26 brachte die Backendfunktionalität wieder. Habe das auch auf einen frischen CMSms 1.12 auf lokalem Server nachvollzogen (beide php 5.5).

Werde wohl ein Bug-Report verfassen. Ist noch keiner darüber vorhanden. Komisch. diese Version ist schon Ende April draußen. Habt einer von euch das auch beobachtet?

Gruß Hani

PS: Hoffentlich mache ich das dann mit dem Bug-Report auch - nach CG-Vorgaben - richtig sad

Offline

#2 27. Mai 2015 13:00

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.079

Re: [GELÖST] FrontEndUsers 1.28 Backendfehler mit CMSms 1.12

PS: Hoffentlich mache ich das dann mit dem Bug-Report auch - nach CG-Vorgaben - richtig

Das kannst Du leider nur dann richtig machen, wenn Du z.B. Franzose und hier völlig unbekannt wärest.

Offline

#3 27. Mai 2015 13:01

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.079

Re: [GELÖST] FrontEndUsers 1.28 Backendfehler mit CMSms 1.12

"Oops"-Fehlermeldung

Stand da wirklich nur "Oops" ?
Kann das nämlich nicht bestätigen.

Offline

#4 27. Mai 2015 19:17

hibr01
hat von CMS/ms gehört
Registriert: 06. Mai 2015
Beiträge: 5

Re: [GELÖST] FrontEndUsers 1.28 Backendfehler mit CMSms 1.12

NaN schrieb:

"Oops"-Fehlermeldung

Stand da wirklich nur "Oops" ?
Kann das nämlich nicht bestätigen.

Hier die Fehlermeldung. Mittlerweile auf CGExtension 1.47.3 geupdated. Habe beide Module per FTP entfernt und per FTP neu installiert. Gleiche Meldung:

Oops!
Sorry, it looks like something went wrong and an error has occurred. 
Don’t worry, it can happen to any of us.
ERROR: at line 179 in file /opt/lampp/htdocs/cmsms/lib/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php:

Message:

Syntax error in template "module_file_tpl:FrontEndUsers;userlist.tpl"  on line 179 "{cgimage image='icons/system/false.gif' alt=$mod->Lang('enable_user')}" unknown tag "module_action_url"

Full Trace:

#0 /opt/lampp/htdocs/cmsms/lib/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php(575): Smarty_Internal_TemplateCompilerBase->trigger_template_error('unknown tag "mo...', 179)
#1 /opt/lampp/htdocs/cmsms/lib/smarty/libs/sysplugins/smarty_internal_templateparser.php(2383): Smarty_Internal_TemplateCompilerBase->compileTag('module_action_u...', Array)
#2 /opt/lampp/htdocs/cmsms/lib/smarty/libs/sysplugins/smarty_internal_templateparser.php(3093): Smarty_Internal_Templateparser->yy_r37()
#3 /opt/lampp/htdocs/cmsms/lib/smarty/libs/sysplugins/smarty_internal_templateparser.php(3191): Smarty_Internal_Templateparser->yy_reduce(37)
#4 /opt/lampp/htdocs/cmsms/lib/smarty/libs/sysplugins/smarty_internal_smartytemplatecompiler.php(111): Smarty_Internal_Templateparser->doParse(3, '}')
#5 /opt/lampp/htdocs/cmsms/lib/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php(273): Smarty_Internal_SmartyTemplateCompiler->doCompile('<script type="t...')
#6 /opt/lampp/htdocs/cmsms/lib/smarty/libs/sysplugins/smarty_internal_template.php(186): Smarty_Internal_TemplateCompilerBase->compileTemplate(Object(Smarty_Internal_Template))
#7 /opt/lampp/htdocs/cmsms/lib/smarty/libs/sysplugins/smarty_internal_templatebase.php(149): Smarty_Internal_Template->compileTemplateSource()
#8 /opt/lampp/htdocs/cmsms/lib/classes/class.Smarty_CMS.php(341): Smarty_Internal_TemplateBase->fetch('module_file_tpl...', NULL, 'FrontEndUsers', NULL, false, false, false)
#9 /opt/lampp/htdocs/cmsms/lib/classes/module_support/modtemplates.inc.php(183): Smarty_CMS->fetch('module_file_tpl...', '', 'FrontEndUsers')
#10 /opt/lampp/htdocs/cmsms/lib/classes/class.CMSModule.php(2908): cms_module_ProcessTemplate(Object(FrontEndUsers), 'userlist.tpl', '', false, '')
#11 /opt/lampp/htdocs/cmsms/modules/FrontEndUsers/function.admin_userstab.php(284): CMSModule->ProcessTemplate('userlist.tpl')
#12 /opt/lampp/htdocs/cmsms/modules/FrontEndUsers/action.defaultadmin.php(96): include('/opt/lampp/htdo...')
#13 /opt/lampp/htdocs/cmsms/lib/classes/class.CMSModule.php(1732): include('/opt/lampp/htdo...')
#14 /opt/lampp/htdocs/cmsms/modules/CGExtensions/CGExtensions.module.php(632): CMSModule->DoAction('defaultadmin', 'm1_', Array, '')
#15 /opt/lampp/htdocs/cmsms/modules/FrontEndUsers/FrontEndUsers.module.php(677): CGExtensions->DoAction('defaultadmin', 'm1_', Array, '')
#16 /opt/lampp/htdocs/cmsms/lib/classes/class.CMSModule.php(1799): FrontEndUsers->DoAction('defaultadmin', 'm1_', Array, '')
#17 /opt/lampp/htdocs/cmsms/admin/moduleinterface.php(91): CMSModule->DoActionBase('defaultadmin', 'm1_', Array)
#18 {main}

Gruß Hani

Offline

#5 27. Mai 2015 19:55

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.825
Webseite

Re: [GELÖST] FrontEndUsers 1.28 Backendfehler mit CMSms 1.12

Das dürfte die entscheidende Stelle sein

hibr01 schrieb:

Syntax error in template "module_file_tpl:FrontEndUsers;userlist.tpl"  on line 179 "{cgimage image='icons/system/false.gif' alt=$mod->Lang('enable_user')}" unknown tag "module_action_url"

Poste mal bitte das userlist.tpl Template bzw. den genauen Befehlsaufruf darin, in dem "module_action_url" vorkommt.

Hast du CGImage auch aktualisiert?


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#6 27. Mai 2015 20:57

hibr01
hat von CMS/ms gehört
Registriert: 06. Mai 2015
Beiträge: 5

Re: [GELÖST] FrontEndUsers 1.28 Backendfehler mit CMSms 1.12

cyberman schrieb:

Poste mal bitte das userlist.tpl Template bzw. den genauen Befehlsaufruf darin, in dem "module_action_url" vorkommt.

Hier die Stelle um Zeile 179 im userlist.tpl:

{if $entry->disabled}
   <a href="{module_action_url action=admin_enable_user uid=$entry->id state=1}">{cgimage image='icons/system/false.gif' alt=$mod->Lang('enable_user')}</a>
{else}
   <a href="{module_action_url action=admin_enable_user uid=$entry->id state=0}">{cgimage image='icons/system/true.gif' alt=$mod->Lang('disable_user')}</a>
{/if}

Hast du CGImage auch aktualisiert?

Benutze ich gar nicht und habe es auch nicht installiert.

Hab jetzt aber mal im org-Forum gesucht und folgendes gefunden: http://forum.cmsmadesimple.org/viewtopic.php?t=72881

Habe also CGSimpleSmarty installiert - et voilà. Fehlermeldung weg. Hatte vorher FEU über den ModuleManager installiert. Der checkt doch die Abhängigkeiten, oder? Und auch in "Module" sollte eine nicht aufgelöste Abhängigkeit auffallen.

Thread gelöst.

Gruß Hani

Beitrag geändert von hibr01 (27. Mai 2015 21:00)

Offline

#7 27. Mai 2015 21:12

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.825
Webseite

Re: [GELÖST] FrontEndUsers 1.28 Backendfehler mit CMSms 1.12

hibr01 schrieb:

Hatte vorher FEU über den ModuleManager installiert. Der checkt doch die Abhängigkeiten, oder?

Sollte er, zumindest theoretisch  devil - aber rate mal, wer dessen Programmierer ist big_smile ...

PS: Habs mal in die Fehlermeldungen verschoben ...


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#8 27. Mai 2015 21:44

hibr01
hat von CMS/ms gehört
Registriert: 06. Mai 2015
Beiträge: 5

Re: [GELÖST] FrontEndUsers 1.28 Backendfehler mit CMSms 1.12

cyberman schrieb:

Sollte er, zumindest theoretisch  devil - aber rate mal, wer dessen Programmierer ist big_smile ....

Ja, ja, ich weiß schon .............

...... der, dessen Namen man nicht nennen darf und der uns nicht mag  wink

Offline

#9 28. Mai 2015 22:25

faglork
CMS/ms-Profi
Ort: Fränkische Schweiz
Registriert: 15. Dezember 2010
Beiträge: 1.150
Webseite

Re: [GELÖST] FrontEndUsers 1.28 Backendfehler mit CMSms 1.12

hibr01 schrieb:

PS: Hoffentlich mache ich das dann mit dem Bug-Report auch - nach CG-Vorgaben - richtig sad

Das geht nur wenn du dich hier nachweisbar abmeldest und dich von diesem Forum glaubwürdig distanzierst.
(Kein Witz)

Servus,
Alex

Offline

#10 28. Mai 2015 22:27

faglork
CMS/ms-Profi
Ort: Fränkische Schweiz
Registriert: 15. Dezember 2010
Beiträge: 1.150
Webseite

Re: [GELÖST] FrontEndUsers 1.28 Backendfehler mit CMSms 1.12

hibr01 schrieb:

JFYI: Nach dem Update von CGExtensions 1.46.4 und v.a. dem FronEndUsers auf 1.28 zeigte letzterer im Backend eine "Oops"-Fehlermeldung. Ich benutze CMsms 1.12.
(

"FEU 1.28 Release Notes:

Note: This version of FEU has undergone signficant changes. There may be some compatibility problems.  However user data should not be lost."

Na dann ist ja alles gut.

Servus
Alex

Offline

#11 28. Mai 2015 22:37

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.825
Webseite

Re: [GELÖST] FrontEndUsers 1.28 Backendfehler mit CMSms 1.12

faglork schrieb:

has undergone signficant changes. There may be some compatibility problems.

Ähmm, gibts die Änderungen und Probleme nicht bei jedem Major Releases seiner Module devil ?


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline