Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 07. November 2011 15:11

NaN
Moderator
Ort: Halle (Saale)
Registriert: 09. November 2010
Beiträge: 4.137

CMS Made Simple 1.10.1 "Le Lorrain" veröffentlicht

Beinahe hätte ich es garnicht bemerkt, aber wie eigentlich kaum anders zu erwarten, wurde am Samstag CMSMS 1.10.1 veröffentlicht:
http://www.cmsmadesimple.org/downloads/

Hier mal eine Liste der Änderungen:

- Behebung eines Fehlers mit HTTPS-Seiten im {metadata} plugin
- Behebung eines Fehlers beim Laden von Modulen im Backend
- Behebung eines kleinen Fehlers in der Konfiguration des MicroTiny
- Behebung eines kleinen Fehlers bei der Ereignisverwaltung
- Zusätzliche Fehlerüberprüfung beim MenüManager und inaktiven Seiten
- Behebung eines Fehlers in der Funktion GetAllContent(), der Auswirkungen auf das Dropdown für übergeordnete Seiten hatte
- Behebung eines Fehlers beim Löschen inaktiver Seiten
- Fehlerbehebung beim Smarty-Modifikator summary
- Die Funktion cms_tree_operations::load_from_list() wurde durch eine einfachere rekursive Funktion ersetzt
- Kleinere Verbesserungen an der Klasse cms_content_cache, um Datenbankabfragen bei inaktiven Seiten zu verringern
- Inaktive Seiten werden nun auch beim Neuordnen der Seiten und in einer anderen Farbe dargestellt
- Kleinere Verbesserungen am ModuleManager und der is_connection_ok Methode
- Entfernung einiger unnötiger Dateien aus dem DB Layer adodb_lite (xmlschema, config etc).
- Fehlerbehebung beim Deinstallieren von inaktiven Modulen
- Behebung der Reihenfolge für page_image und thumbnail Dropdowns
- Behebung eines Fehlers in der Funktion GetParameters im Modul-API, wodurch Parameter in der Hilfe nicht angezeigt wurden, wenn das Modul die neue Funktion InitializAdmin verwendet
- Behebung eines Kompatibilitätsproblems mit Postgres
- Behebung eines Fehlers in der Paginierung in der Administration des News Moduls, wenn nur bestimmte Kategorien angezeigt werden sollen
- Kleinere Fehlerbehebungen beim News-Upgrade
- Kleinere Fehlerbehebungen in der Klasse Pageinfo.
- Fehlerbehebung in der Funktion GetModulesWithCapability
- Hilfe für den MicroTiny ergänzt
- Adds more help for the tag. (keine Ahnung, was damit gemeint ist)
- Fehlerbehebung in der Umleitungsfunktion des Modul API, wenn der Wert eines Parameters 0 war
- Erweiterung des Zeitlimits im ModulManager für zeitintensive Operationen (funktioniert bei einigen Providern nicht).
- Kleinere Fehlerbehebungen im News-Template

Original Nachricht kann wie immer hier nachgelesen werden: http://forum.cmsmadesimple.org/viewtopi … =1&t=57712

Offline

#2 07. November 2011 17:31

Henk1060
Server-Pate
Registriert: 12. August 2011
Beiträge: 632

Re: CMS Made Simple 1.10.1 "Le Lorrain" veröffentlicht

Habe mir gerade die Neue Version eingespielt. ich zittere noch immer  wink
Im grossen und ganzen alles geklappt bis auf den vorletzten punkt, ein fehler vom such modul per ftp entfernt und dann gings weiter.

Auch das Modul TinymCE hatte etwas herum gezickt neu installiert mit Ftp  browser cache geleert dann ging wieder alles. 

Vielleicht hilft es wenn...

Offline

#3 08. November 2011 03:20

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.878
Webseite

Re: CMS Made Simple 1.10.1 "Le Lorrain" veröffentlicht

Henk1060 schrieb:

ein fehler vom such modul per ftp entfernt

Details? Bugreport?


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#4 08. November 2011 07:19

Henk1060
Server-Pate
Registriert: 12. August 2011
Beiträge: 632

Re: CMS Made Simple 1.10.1 "Le Lorrain" veröffentlicht

Hy Cyberman,
In der Aufregung habe ich den fehler code nicht kopiert ;(
muss aber noch einen 2 server updaten vielleicht tritt der Fehler noch einmal auf , dann werde ich den fehler posten.

Offline

#5 09. November 2011 05:25

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.878
Webseite

Re: CMS Made Simple 1.10.1 "Le Lorrain" veröffentlicht

NaN schrieb:

- Adds more help for the tag. (keine Ahnung, was damit gemeint ist)

http://viewsvn.cmsmadesimple.org/log.ph … madesimple

Revision 7504

SVN schrieb:

Improved help to the {content_module} tag


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#6 10. November 2011 10:13

kampkrusty
Server-Pate
Registriert: 03. April 2011
Beiträge: 263

Re: CMS Made Simple 1.10.1 "Le Lorrain" veröffentlicht

Henk1060 schrieb:

Auch das Modul TinymCE hatte etwas herum gezickt neu installiert mit Ftp  browser cache geleert dann ging wieder alles.

Welche Version nutzt du?


ff-jena-mitte.de

Offline

#7 10. November 2011 14:47

Andiministrator
Kabeljungwerker
Ort: Plauen / Vogtland
Registriert: 09. November 2010
Beiträge: 264
Webseite

Re: CMS Made Simple 1.10.1 "Le Lorrain" veröffentlicht

Hier meine Erfahrung:
Bei einem Update von 1.9.4.3 auf 1.10.1 bleibt bei mir die Installation bei Punkt 6 (ohne Meldung oder sonstiges) hängen. Danach laufen weder Backend noch Frontend mehr - es wird einfach gar nichts mehr angezeigt.

Ich probiere nun einmal den Zwischenschritt über die Version 1.10
UPDATE: Selbes Problem.


Arbeitet bei conversearch GmbH: http://conversearch.de (Webseiten-Analyse und -Monitoring)
Bloggt bei Andiministrator.de: http://andiministrator.de

Offline

#8 10. November 2011 14:56

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.878
Webseite

Re: CMS Made Simple 1.10.1 "Le Lorrain" veröffentlicht

Hast du mal alle PHP Fehlermeldungen Optionen aktiviert?


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#9 10. November 2011 15:21

Andiministrator
Kabeljungwerker
Ort: Plauen / Vogtland
Registriert: 09. November 2010
Beiträge: 264
Webseite

Re: CMS Made Simple 1.10.1 "Le Lorrain" veröffentlicht

Guter Hinweis  glasses
Hab mal im Error-Log nachgeschaut, scheint am Captcha-Modul zu liegen:

[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP Fatal error:  Cannot override final method CMSModule::GetModulePath() in X:\\web\\hzp-usedom.de\\htmldoc\\modules\\Captcha\\lib\\classes\\module\\class.captcha.php on line 1048, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP Stack trace:, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP   1. {main}() X:\\web\\hzp-usedom.de\\htmldoc\\install\\upgrade.php:0, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP   2. CMSInstaller->run() X:\\web\\hzp-usedom.de\\htmldoc\\install\\upgrade.php:158, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP   3. CMSInstallerPage->displayContent() X:\\web\\hzp-usedom.de\\htmldoc\\install\\lib\\classes\\CMSInstaller.class.php:132, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP   4. CMSInstallerPage6->assignVariables() X:\\web\\hzp-usedom.de\\htmldoc\\install\\lib\\classes\\CMSInstallerPage.class.php:57, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP   5. ModuleOperations->LoadModules() X:\\web\\hzp-usedom.de\\htmldoc\\install\\lib\\classes\\CMSUpgradePage6.class.php:26, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP   6. ModuleOperations->get_module_instance() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\classes\\class.moduleoperations.inc.php:781, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP   7. ModuleOperations->_load_module() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\classes\\class.moduleoperations.inc.php:1043, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP   8. class_exists() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\classes\\class.moduleoperations.inc.php:566, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP   9. cms_autoloader() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\autoloader.php:0, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP  10. ContentOperations->ListContentTypes() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\autoloader.php:86, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP  11. ContentOperations->_get_content_types() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\classes\\class.contentoperations.inc.php:413, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP  12. module_meta->module_list_by_method() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\classes\\class.contentoperations.inc.php:342, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP  13. ModuleOperations->get_module_instance() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\classes\\class.module_meta.php:189, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP  14. ModuleOperations->_load_module() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\classes\\class.moduleoperations.inc.php:1043, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP  15. class_exists() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\classes\\class.moduleoperations.inc.php:566, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP  16. cms_autoloader() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\autoloader.php:0, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP  17. __cms_load() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\autoloader.php:97, referer: http://www.hzp/install/upgrade.php
[Thu Nov 10 15:17:47 2011] [error] [client 127.0.0.1] PHP  18. require_once() X:\\web\\hzp-usedom.de\\htmldoc\\lib\\autoloader.php:39, referer: http://www.hzp/install/upgrade.php

UPDATE:
Ok, es lag nicht nur an dem Captcha-Modul, sondern auch noch am Guestbook- und Cataloger-Modul.
Nachdem ich die alten Dateien der Module durch die der neuen Versionen ersetzt hatte, lief das Update durch.


Arbeitet bei conversearch GmbH: http://conversearch.de (Webseiten-Analyse und -Monitoring)
Bloggt bei Andiministrator.de: http://andiministrator.de

Offline

#10 10. November 2011 22:11

nockenfell
Moderator
Ort: Lenzburg, Schweiz
Registriert: 09. November 2010
Beiträge: 2.807
Webseite

Re: CMS Made Simple 1.10.1 "Le Lorrain" veröffentlicht

Andiministrator schrieb:

UPDATE:
Ok, es lag nicht nur an dem Captcha-Modul, sondern auch noch am Guestbook- und Cataloger-Modul.
Nachdem ich die alten Dateien der Module durch die der neuen Versionen ersetzt hatte, lief das Update durch.

Das aktualisieren der Module ist einer der wichtigsten Schritte vor dem Update.


[dieser Beitrag wurde mit 100% recycled bits geschrieben]
Mein Blog  /   Diverse Links rund um CMS Made Simple
Module: btAdminer, ToolBox

Offline

#11 11. November 2011 11:16

rage_all
arbeitet mit CMS/ms
Ort: Augsburg
Registriert: 09. März 2011
Beiträge: 281

Re: CMS Made Simple 1.10.1 "Le Lorrain" veröffentlicht

Hallo,

ich hab gestern eine frische Installation durchgeführt und folgendes festgestellt:

  • Installationsroutine hat eine gefühlte Ewigkeit gedauert

Andere Websites auf demselben Server waren einwandfrei verfügbar, auch die "alte" CMS Installation auf der anderen Subdomain reagierte gewohnt schnell. Nur die Prüfungen während dem Installationsvorgang waren atemberaubend langsam. Nach Abschluss der Installation war alles wieder okay...

  • Captcha Modul war im Repository verfügbar, wirft aber Fehlermeldungen (nur im Admin - Frontend ist okay)

CMSms Backend schrieb:

Indirect modification of overloaded property CmsObject::$db has no effect in ... odule/class.captcha.php on line 188

Soweit ich das nachgeschlagen habe, bedeutet es nur, dass dieses Modul nicht mit dem System synchron arbeitet. Solange es seine Arbeit macht und nicht den Cache mit alten Captchas sprengt, regt mich das aber nicht auf.

  • Es dauerte eine gefühlte Ewigkeit, bis die Warnmeldung, dass CMSMailer nicht eingestellt ist, wieder verschwand

Nach der Installation lösche ich zuerst das Installationsverzeichnis und stelle sofort danach die Emaileinstellungen mit SMTP ein. In den "alten" Versionen verschwand sofort danach der Hinweis. Seit (dem neuen) 1.xx muss das wohl anders laufen, weil auch in der Hilfe stand, dass es einige Zeit dauern kann bis der Hinweis weg ist. Das kannte ich von keiner der vorigen Versionen.
Nur zur Sicherheit: Cache ist bei mir während der Entwicklung Standardmäßig deaktiviert; sowohl im Browser als auch im CMS.

Aber im Großen und Ganzen finde ich das neue nicht schlechter als das alte.
Nach der Ankündigung des neuen 1.x und dem ganzen Theater mit dem .org Board, den Devs, etc. dachte ich, es wäre Not nur noch mit den 1.9xx zu arbeiten, bis sich alles wieder normalisiert hat. Damit war ich wohl zu voreilig. CMSMS ist einfach und zuverlässig wie seit je her gewohnt und ich bin dankbar für die Arbeit die hier investiert wird.

Ich bin auf die "ganz Großen" Verbesserungen gespannt, die mit 2.xx umgesetzt werden sollten. Bestimmt ist in der jetzigen Version schon ganz viel im Getriebe, aber ich bin kein Coder - von den vielen kleinen Zahnrädchen im Hintergrund verstehe ich nichts.  wink
Für das Backend konnte ich bislang nicht viel neues ausmachen. MicroTiny ist ganz nett und für die User sicher einfach zum Content nacharbeiten - zum Neu erstellen von komplexeren Inhalten finde ich ihn aber zu schwach...

So. Soviel zu meinem rudimentären Senf...  big_smile

Offline