Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 08. November 2014 22:33

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.825
Webseite

PHP-Version & Calguy's (CG) Module

Der Support für die PHP-Version 5.3 ist ausgelaufen!

Demgemäß setzen alle Module mit dem Kürzel CG als Präfix künftig PHP 5.4 voraus:

http://forum.cmsmadesimple.org/viewtopi … =7&t=71719


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#2 11. November 2014 15:16

jeff1980
Server-Pate
Ort: Dortmund
Registriert: 26. November 2010
Beiträge: 597

Re: PHP-Version & Calguy's (CG) Module

Tja, leider setzt z.B. Host Europe immer noch auf 5.3.29 (ohne Option zur Umstellung). Langsam kommen mir Zweifel, ob sie immer noch zu den besten Hostern gehören ... Ich habe grad noch mal nachgefragt, wie dort die Pläne sind. Aber schon vor einigen Monaten hieß es, sie arbeiten dran.

Zudem hatte ich in letzter Zeit extreme Schwierigkeiten mit Verbindungsabbrüchen zu diversen Seite die dort gehostet sind. Andere Seiten waren immer erreichbar und die Recherche seitens Host Europe (z.B. mit Traceroute) hat auch nichts ergeben.

Offline

#3 11. November 2014 21:16

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.825
Webseite

Re: PHP-Version & Calguy's (CG) Module

Stehe mit meinem Reseller-Account bei all-inkl.com vor dem gleichen Problem. Auch da ist nix mehr mit umschalten. Jedoch ermöglichen sie es, mit dem Account ohne zusätzliche Kosten auf einen Webserver mit der aktuellen PHP-Version umzuziehen.


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#4 12. November 2014 11:53

rage_all
arbeitet mit CMS/ms
Ort: Augsburg
Registriert: 09. März 2011
Beiträge: 273

Re: PHP-Version & Calguy's (CG) Module

Ich kann nur DomainFactory empfehlen. Zwar höre ich immer wie teuer die seien, und das es woanders um soviel billiger wäre, aber wenn ich überlege:
Komplettes Reseller-Programm, inkl. Rechnungsmodul (und Bank-Datenträgerexport) und frei entwickelbaren Tarifen, Rechnungsbögen (mit Smarty-Templates) mit automatischer Generierung über Nacht via Mailversand, Bereitstellung gültiger Beispiel-AGB für die Diensteerbringung als Hoster, ordentliche DENIC-Information ohne Trace auf D)F als Rechenzentrum, kostenloser Schutz vor Überlastungen (in Grenzen) z.B. wg. TV-Werbung, etc., etc.

Für jeden Tarif ist die Anzahl der Subdomains, Cronjobs, Mailspace, Scriptlaufzeit, SQL-DBs, SSH-Accounts, SPAM-Filter, Viren-Scanner, Exchange, Streaming, FTP, Traffic, Quota, etc., etc., etc. einstellbar.
Eigentlich sind es mir beinahe zuviele Optionen - aber kostenlose Hotline mit kompetenten Mitarbeitern die normalerweise in weniger als 2 Minuten am Telefon sind und noch während des Gesprächs eine Lösung am Start haben - das ist der Knaller und mir auch jeden einzelnen Cent der Kosten Wert.

Und was die PHP-Versionen angeht, sind das hier die derzeit (für jeden Ordner einzeln) verfügbaren Versionen:
4.4.9
5.2.17
5.3.26
5.3.28
5.4.16
5.4.30
5.4.9
5.5.14
5.6.0
5.6.2
Mittels php.ini eingestellt überfährt das auch die sonst gültige für den Server globale und Domain-globale Einstellung.
Der letzte Ausfall liegt mehr als drei Jahre zurück. Da hat mir die Geschäftsleitung um sechs Uhr früh eine Email geschickt, dass mein Server um drei Uhr morgens für 8 Minuten still stand. Ich möge doch bitte den mir entstandenen Ausfall rechnen und reinschicken zur Regulierung. Dabei haben die "nur" 99,9% Uptime-Garantie.

Ich hoffe das hat sich jetzt nicht gelesen als wäre ich der Vertreter von D)F — aber wer zufrieden ist, schwärmt...  big_smile

Offline

#5 12. November 2014 14:45

jeff1980
Server-Pate
Ort: Dortmund
Registriert: 26. November 2010
Beiträge: 597

Re: PHP-Version & Calguy's (CG) Module

Preislich tun sich gute Anbieter glaube ich eh nicht viel. Und wer da spart, ist imho eh selbst schuld ...

Der Kontakt mit Host Europe hat übrigens ergeben, dass man auf Anfrage an einer Beta-Phase für PHP 5.4(.34) teilnehmen kann. Und dann ist es auch so, dass man pro Verzeichnis wählen kann und die Umstellung in Echtzeit passiert.
Einen genauen Zeitplan für die offizielle Umstellung gibt es aber nicht.
Immerhin ist es jetzt besser gelöst als beim Schritt von 5.2 auf 5.3 - da musste man das komplette Paket umstellen und konnte nur ein oder zwei Mal zurück wechseln.

Offline

#6 13. November 2014 17:21

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.825
Webseite

Re: PHP-Version & Calguy's (CG) Module

rage_all schrieb:

Ich hoffe das hat sich jetzt nicht gelesen als wäre ich der Vertreter von D)F

Hast du 'ne Peilung hinsichtlich deren "JiffyBox"?

Hab nur deren Werbung dafür gesehen und mich gefragt, ob es Sinn machen würde, dahin zu wechseln (im Vergleich zu einem ManagedServer).


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#7 14. November 2014 15:34

rage_all
arbeitet mit CMS/ms
Ort: Augsburg
Registriert: 09. März 2011
Beiträge: 273

Re: PHP-Version & Calguy's (CG) Module

Nee, ich hab für so große Dinger keine Verwendung.
Ich bin ja schon froh, dass die alles managen - mal ehrlich, ich schaff es ja sogar regelmäßig mein Ubuntu zu schrotten...  sad
An dieser Stelle kommt dann auch mein üblicher Spruch: »I'm a designer, not a coder«. big_smile

Aber ich denke das mal zu testen wäre kein finanzielles Desaster.
z.B.: 4GB RAM, 4 CPU-Kerne, 150GB Plattenplatz:
0,04 € / h im Betrieb und 0,01 € / h im Hibernate
(wobei das ja Leistungsmäßig bis 32GB RAM und Octacore geht)

24h gratis testen geht glaube ich rund ums Jahr; außerdem gibt es zurzeit 50 € bei Registrierung eines neuen JiffyBox-Accounts als Gutschrift auf die Rechnung (höchstens aber bis bis 31.12.2014 - was da noch davon steht, verfällt halt).

Offline

#8 14. November 2014 15:51

Cherry
CMS/ms-Profi
Registriert: 15. Dezember 2010
Beiträge: 529

Re: PHP-Version & Calguy's (CG) Module

cyberman schrieb:

Hast du 'ne Peilung hinsichtlich deren "JiffyBox"?

Ist prinzipiell ne feine Sache. Du mußt dich dabei aber halt um alles selber kümmern. Die ganzen Sicherheitsupdates usw.
Da braucht man glaube ich schon ne gehörige Portion Systemkenntnis für. Ich könnt's nicht und bin froh, wenn sich bei meinem shared Webspace andere darum kümmern, die (hoffentlich) Ahnung davon haben. Wenn man andererseits dann eben auch eingeschränkt ist, indem was man tun und lassen kann, PHP Version usw.

Offline

#9 15. November 2014 21:25

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.825
Webseite

Re: PHP-Version & Calguy's (CG) Module

Danke fürs Feedback - da bleib ich doch lieber beim ManagedServer wink.


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#10 03. Januar 2015 14:22

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.825
Webseite

Re: PHP-Version & Calguy's (CG) Module

cyberman schrieb:

PHP 5.3 wird nicht länger weiterentwickelt, demgemäß setzen alle Module mit dem Kürzel CG vornan künftig PHP 5.4 voraus:

http://forum.cmsmadesimple.org/viewtopi … =7&t=71719

Der nächste Schritt zu PHP 5.5 zeichnet sich bereits ab

http://forum.cmsmadesimple.org/viewtopi … 82#p318782


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#11 07. Januar 2015 09:58

Dancer62
Server-Pate
Ort: 26345 Bockhorn, Niedersachsen
Registriert: 08. November 2013
Beiträge: 380

Re: PHP-Version & Calguy's (CG) Module

cyberman schrieb:

Der nächste Schritt zu PHP 5.5 zeichnet sich bereits ab

http://forum.cmsmadesimple.org/viewtopi … 82#p318782

Hab' ich ein Glück - ich habe gerade 'meinen' Server auf PHP 5.5.18 umstellen lassen. Sollte also auch für die Zukunft reichen...  smile


Man ist so alt, wie man sich fühlt...

Offline

#12 10. Dezember 2015 11:00

Klinge
probiert CMS/ms aus
Ort: Stuttgart / BW
Registriert: 27. September 2011
Beiträge: 34

Re: PHP-Version & Calguy's (CG) Module

Ich hab ein Managed Server bei InternetX in Nürnberg stehen. Bin mit dem Service super zufrieden. Support hilft immer weiter! Meine Seiten laufen auf FastCGI und kann mir alle PHP Versionen wo ich benötige installieren lassen und habe somit die volle Auswahl von 5.3 bis 7.0 . Im Moment belasse ich es aber bei PHP 5.6

Ja Sie sind nicht günstig, aber für die Leistung was Sie bringen, ist dass das Geld auch wert.

Beitrag geändert von Klinge (10. Dezember 2015 11:04)

Offline

#13 30. Dezember 2015 09:09

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.825
Webseite

Re: PHP-Version & Calguy's (CG) Module

Wie aktuell zu erfahren ist

http://forum.cmsmadesimple.org/viewtopic.php?t=74024

sind die Module mit dem Präfix CG... ab Release-Datum März 2016 "CMSMS 2.x Only", also nur noch für CMSMS 2 verwendbar.


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#14 30. Dezember 2015 11:09

Dancer62
Server-Pate
Ort: 26345 Bockhorn, Niedersachsen
Registriert: 08. November 2013
Beiträge: 380

Re: PHP-Version & Calguy's (CG) Module

cyberman schrieb:

sind die Module mit dem Präfix CG... ab Release-Datum März 2016 "CMSMS 2.x Only", also nur noch für CMSMS 2 verwendbar.

Das bedeutet de facto eine Abkündigung des Supports dieser Module deutlich vor Ende des offiziellen Supports der 1.x-Versionen im September 2016...  mad


Man ist so alt, wie man sich fühlt...

Offline

#15 30. Dezember 2015 11:46

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.825
Webseite

Re: PHP-Version & Calguy's (CG) Module

Yep ... hatte mich bereits hier mit diesem Thema näher auseinander gesetzt.


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline