Du bist nicht angemeldet. Der Zugriff auf einige Boards wurde daher deaktiviert.

#1 03. Oktober 2016 09:36

redigo/
Server-Pate
Ort: Zürich
Registriert: 20. Januar 2011
Beiträge: 485
Webseite

[GELÖST] Unerwünschter <p>-Tag

Hallo
CMSMS 5.2: Wenn ich in einer Contentbox einen Tag wie z.B. {Gallery} einfüge, setzt das System diesen Tag in eine Textzeile: <p>{Gallery}</p>. Das Ergebnis ist eine unerwünschte leere Zeile oberhalb des Gallery-Bildes. Im Tiny zeigt die Option «Quelltext» zwar diese <p>-Tags an. Aber entfernen lassen sie sich nicht.
Unter 1.12 gab es diseses Problem nicht. Scheint ein «Fortschritt» von 2.x zu sein ;-)
Danke für hilfreiche Antworten.
redigo/

Offline

#2 03. Oktober 2016 15:24

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.878
Webseite

Re: [GELÖST] Unerwünschter <p>-Tag

redigo/ schrieb:

CMSMS 5.2:

Die Version kenne ich noch gar nicht tongue

redigo/ schrieb:

Im Tiny zeigt die Option «Quelltext» zwar diese <p>-Tags an. Aber entfernen lassen sie sich nicht.
Unter 1.12 gab es diseses Problem nicht. Scheint ein «Fortschritt» von 2.x zu sein ;-)

Hängt mit der neuen Version des darunter liegenden TinyMCE zusammen ...

redigo/ schrieb:

Danke für hilfreiche Antworten.

Die Lösung kennst du ja bereits wink

https://forum.cmsmadesimple.org/viewtop … 81#p330281

Dies lässt sich bei Bedarf über einen Eingriff in der Konfigurationsdatei auch für den MicroTiny umsetzen wink.

Die Datei /modules/MicroTiny/templates/tinymce_config.js mit dem Editor eurer Wahl öffnen. Dort sucht ihr die Zeile mit

und direkt dahinter (auf einer neuen Zeile) fügt ihr folgendes ein

Beitrag geändert von cyberman (03. Oktober 2016 15:26)


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#3 03. Oktober 2016 15:47

nockenfell
Moderator
Ort: Lenzburg, Schweiz
Registriert: 09. November 2010
Beiträge: 2.807
Webseite

Re: [GELÖST] Unerwünschter <p>-Tag

Das hängt nicht direkt mit CMSMS 2.x zusammen, sondern eher mit dem aktuelleren TinyMCE. Mit folgenden Tricks kannst du den P-Tag umgegen:

  • Ganz rechts hat es das Icon <>. Damit öffnest du die Quelltextansicht. Nun kannst du alles geraus löschen und den {Gallery} Tag einfügen. Dieser hat danach keine <p>-Tags. Auch weitere Absätze sollte er in der Standardeinstellung (wie sie auf deiner himmel-Seite ist, nicht mehr produzieren, wenn du Enter drückst.

  • Weitere Variante: Beim bearbeiten der Seite auf den Reiter "Optionen" gehen und zuunterst die Option "WYSIWYG für diese Seite nicht erlauben" aktivieren. Damit kannst du nur reinen Quelltext eingeben, was beim Einfügen des Gallery-Tags wahrscheinlich auch gewünscht ist.


[dieser Beitrag wurde mit 100% recycled bits geschrieben]
Mein Blog  /   Diverse Links rund um CMS Made Simple
Module: btAdminer, ToolBox

Offline

#4 03. Oktober 2016 15:49

nockenfell
Moderator
Ort: Lenzburg, Schweiz
Registriert: 09. November 2010
Beiträge: 2.807
Webseite

Re: [GELÖST] Unerwünschter <p>-Tag

cyberman schrieb:

Im TinyMCE ist diese Option standardmässig so eingestellt. Wenn allerdings schon <p>-Tags im Quelltext vorhanden sind, bringt man diese nur mit dem Löschen über den Quelltext raus. Zu testen z.B. im Test-Fenster der TinyMCE Einstellungen.


[dieser Beitrag wurde mit 100% recycled bits geschrieben]
Mein Blog  /   Diverse Links rund um CMS Made Simple
Module: btAdminer, ToolBox

Offline

#5 06. Oktober 2016 06:43

redigo/
Server-Pate
Ort: Zürich
Registriert: 20. Januar 2011
Beiträge: 485
Webseite

Re: [GELÖST] Unerwünschter <p>-Tag

Danke euch allen, damit ist mein Problem gelöst und gelernt habe ich dabei gleich auch noch etwas ;-)
redigo/

Offline

#6 06. Oktober 2016 19:32

owr_web
Server-Pate
Registriert: 16. Dezember 2010
Beiträge: 537

Re: [GELÖST] Unerwünschter <p>-Tag

Aber dazu brqaucht man ja nicht in die .js eingreifen, da reicht bei den Tiny-Einstellungen ein Häkchen zu setzen oder auch nicht.

tiny schrieb:

Bei Zeilenumbruch Absatz erzwingen

Haken weg und es wird kein Absatz gemacht - Enter mach eine Zeilenschaltung und Shift+Enter macht den Absatz.

Offline

#7 08. Oktober 2016 12:26

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.878
Webseite

Re: [GELÖST] Unerwünschter <p>-Tag

owr_web schrieb:

Aber dazu braucht man ja nicht in die .js eingreifen, da reicht bei den Tiny-Einstellungen ein Häkchen zu setzen oder auch nicht.

Wie gesagt

cyberman schrieb:

Dies lässt sich bei Bedarf über einen Eingriff in der Konfigurationsdatei auch für den MicroTiny umsetzen

denn da gibt's diese Option nicht wink.


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline

#8 08. Oktober 2016 18:29

owr_web
Server-Pate
Registriert: 16. Dezember 2010
Beiträge: 537

Re: [GELÖST] Unerwünschter <p>-Tag

Tja, wer lesen kann ist definitiv klar im Vorteil - ok, hast mich überzeugt. Nachdem ich den Micro nicht wirklich mag, hab ich das glatt überlesen  cool  glasses  wink

Offline

#9 08. Oktober 2016 19:04

cyberman
Moderator
Ort: Dohna / Sachsen
Registriert: 13. September 2010
Beiträge: 6.878
Webseite

Re: [GELÖST] Unerwünschter <p>-Tag

Ist doch nicht schlimm ... dafür gucken wir doch hier im Team drauf - Schwarm-Intelligenz, oder wie sich das nennt big_smile .


1. Wie bekomme ich hier schnelle Hilfe?
2. HowTo: Fehlersuche bei CMS/ms
---
„First they ignore you, then they laugh at you, then they fight you, then you win.“ Mahatma Ghandi

Offline